Joomlabamboo template and extension documentation


Since the release of K2 v2.5, K2 has used jQuery as it's main javascript engine.

JQuery is a wonderful javascript library that generally sits well next to the core Joomla Mootools javascript library. Our templates and extensions use jQuery in no conflict mode so conflicts with other extensions while they can happen, are rare.

The main cause of jQuery javascript conflicts is when multiple versions of jQuery are loading on the page. This can happen if the module, plugin, template you are using also loads it's own version of the jQuery library.

K2 is set to load jQuery by default and tends to load it's version of jQuery after the Zen grid framework has also loaded it's own version. This will tend to result in our superfish menu or hidden panel not working. 

If this is what you are experiencing on your site then there are two ways to solve the issue.

Disable the K2 version of jQuery

1. Navigate to the K2 administration area in your Joomla administrator.

a. Navigate to

b. Once logged in navigate to components > k2 via the top menu

c. Once there click on the parameters icon.



2. K2 is set to load the latest version of jQuery via google by default.



3. Set the k2 jQuery option to "Do not load the jQuery library".


2. Loading the latest version of jQuery via google.

Another way to ensure that there is only one version of jQuery loading on the page is to set the framework or JB LIbrary version of jQuery to use the latest available version of jQuery and to load it via Google. 

This works because when the browser sees that the same file is being requested twice then it only loads the first instance. 


1. Setting JB Library to use the latest available.

a. Navigate to extensions > plugin manager

b. Filter the plugins listed via the folder filter to system.



c. Click on the JB Library listing.



d. Set the jQuery version loaded by the JB LIbrary to Latest version of jQuery and the jQuery source to google. 



2. Loading the latest version of jQuery via google in your zen grid framework compatible template.

This option is available for all templates that are compatible with Zengridframework v2.2+ and JB Library v1.3+.


a. Navigate to the template manager in your Joomla administrator.

b. Click on your Zen grid framework template name.


c. Navigate to the settings tab in the Zen grid framework interface.



3. Scroll down to the bottom of the settings page and set the version of jQuery to be the latest and set jQuery to load from google.