Joomlabamboo template and extension documentation

For all Joomla 3+ templates built using the Zen Grid Framework v4 (any theme after October 2014) please refer to the Zen Grid Framework v4 documentation.

one of the options on the overview page in the Zen Grid Framework is the option to disable the root check. As a safety the framework compatible template checks for the existence of the core framework files by placing a standard if variable around the core require task. In simple terms the template looks for the framework and loads it if it can find the appropriate files.


In some cases and mostly with windows servers this root check comes back as null even though the framework may exist. In these cases we have created the option to disable the root check in the template so as to avoid an unnecessary warning and an error message that suggests you should install the Zen Grid Framework.

If you are hosting your site on a windows server and you have installed the Zen Grid Framework core files and you still receive this error message then disabling the root check on the overview page will get the framework loading correctly on your site.